Basic EIGRP Configuration and Verification (Free Preview)

You must first complete Implementing EIGRP for IPv4 before viewing this Lesson
This is a preview lesson. Please purchase the course to access all lessons.

It’s time to get our hands dirty. Let’s configure EIGRP on all 3 routers as per the below instructions.

Tasks

  • Configure EIGRP 777 on all routers.
  • Use specific wildcard mask when advertising connected networks.
  • Verify the EIGRP configuration.
  • Upon completing this task, you should be able to ping from each others Loopback0 networks.

Configuration

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router eigrp 777
R1(config-router)#network 10.1.12.0 0.0.0.255
R1(config-router)#network 10.1.13.0 0.0.0.255
R1(config-router)#network 1.1.1.1 0.0.0.0
R1(config-router)#end



R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router eigrp 777
R2(config-router)#network 10.1.12.0 0.0.0.255
R2(config-router)#network 10.1.23.0 0.0.0.255
R2(config-router)#network 2.2.2.2 0.0.0.0
R2(config-router)#end



R3#conf t
R3(config)#router eigrp 777
R3(config-router)#network 10.1.13.0 0.0.0.255
R3(config-router)#network 10.1.23.0 0.0.0.255
R3(config-router)#network 3.3.3.3 0.0.0.0
R3(config-router)#end

 

Verification

 

show ip protcols

Firstly, let’s look at the show ip protcols command. The show ip protocols command can be used to list a shorthand version of the EIGRP configuration.


R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "eigrp 777"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(777)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    Soft SIA disabled
    NSF-aware route hold timer is 240
    Router-ID: 1.1.1.1
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    1.1.1.1/32
    10.1.12.0/24
    10.1.13.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.13.3             90      00:00:26
    10.1.12.2             90      00:00:26
  Distance: internal 90 external 170
  
  
R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "eigrp 777"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(777)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    Soft SIA disabled
    NSF-aware route hold timer is 240
    Router-ID: 2.2.2.2
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    2.2.2.2/32
    10.1.12.0/24
    10.1.23.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.12.1             90      00:12:17
    10.1.23.3             90      00:12:17
  Distance: internal 90 external 170
  
  
R3#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "eigrp 777"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(777)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    Soft SIA disabled
    NSF-aware route hold timer is 240
    Router-ID: 3.3.3.3
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    3.3.3.3/32
    10.1.13.0/24
    10.1.23.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.13.1             90      00:12:26
    10.1.23.2             90      00:12:26
  Distance: internal 90 external 170

 

 

show ip eigrp neighbors

The show ip eigrp neighbors command lists all EIGRP neighbors.


R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(777)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.1.13.3               Gi0/3                    14 00:11:24   16   100  0  10
0   10.1.12.2               Gi0/2                    12 00:12:45   14   100  0  11
R1#


R2#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(777)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.1.23.3               Gi0/3                    10 00:11:12   16   100  0  9
0   10.1.12.1               Gi0/1                    11 00:12:45  659  3954  0  9
R2#


R3#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(777)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.1.23.2               Gi0/2                    12 00:11:12 1268  5000  0  10
0   10.1.13.1               Gi0/1                    13 00:11:24  824  4944  0  10
R3#

 

 

show ip route eigrp

Let’s look at the show ip route eigrp command. The show ip route commad dsplays the router’s routing table where as the show ip route eigrp shows only the EIGRP routing entries in the routing table.


R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/130816] via 10.1.12.2, 00:12:31, GigabitEthernet0/2
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/130816] via 10.1.13.3, 00:12:22, GigabitEthernet0/3
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.1.12.0/24 is directly connected, GigabitEthernet0/2
L        10.1.12.1/32 is directly connected, GigabitEthernet0/2
C        10.1.13.0/24 is directly connected, GigabitEthernet0/3
L        10.1.13.1/32 is directly connected, GigabitEthernet0/3
D        10.1.23.0/24 [90/3072] via 10.1.13.3, 00:12:33, GigabitEthernet0/3
                      [90/3072] via 10.1.12.2, 00:12:33, GigabitEthernet0/2
					  

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/130816] via 10.1.12.2, 00:12:41, GigabitEthernet0/2
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/130816] via 10.1.13.3, 00:12:32, GigabitEthernet0/3
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.1.23.0/24 [90/3072] via 10.1.13.3, 00:12:43, GigabitEthernet0/3
                      [90/3072] via 10.1.12.2, 00:12:43, GigabitEthernet0/2

					  

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/130816] via 10.1.12.1, 00:12:31, GigabitEthernet0/1
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/130816] via 10.1.23.3, 00:12:23, GigabitEthernet0/3
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.1.12.0/24 is directly connected, GigabitEthernet0/1
L        10.1.12.2/32 is directly connected, GigabitEthernet0/1
D        10.1.13.0/24 [90/3072] via 10.1.23.3, 00:12:31, GigabitEthernet0/3
                      [90/3072] via 10.1.12.1, 00:12:31, GigabitEthernet0/1
C        10.1.23.0/24 is directly connected, GigabitEthernet0/3
L        10.1.23.2/32 is directly connected, GigabitEthernet0/3


R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/130816] via 10.1.12.1, 00:12:40, GigabitEthernet0/1
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/130816] via 10.1.23.3, 00:12:32, GigabitEthernet0/3
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.1.13.0/24 [90/3072] via 10.1.23.3, 00:12:40, GigabitEthernet0/3
                      [90/3072] via 10.1.12.1, 00:12:40, GigabitEthernet0/1



R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/130816] via 10.1.13.1, 00:12:31, GigabitEthernet0/1
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/130816] via 10.1.23.2, 00:12:31, GigabitEthernet0/2
      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.1.12.0/24 [90/3072] via 10.1.23.2, 00:12:31, GigabitEthernet0/2
                      [90/3072] via 10.1.13.1, 00:12:31, GigabitEthernet0/1
C        10.1.13.0/24 is directly connected, GigabitEthernet0/1
L        10.1.13.3/32 is directly connected, GigabitEthernet0/1
C        10.1.23.0/24 is directly connected, GigabitEthernet0/2
L        10.1.23.3/32 is directly connected, GigabitEthernet0/2



R3#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/130816] via 10.1.13.1, 00:12:40, GigabitEthernet0/1
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/130816] via 10.1.23.2, 00:12:40, GigabitEthernet0/2
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D        10.1.12.0/24 [90/3072] via 10.1.23.2, 00:12:40, GigabitEthernet0/2
                      [90/3072] via 10.1.13.1, 00:12:40, GigabitEthernet0/1					  
		  

 

show ip eigrp topology

Fourthly, let’s examine what we can learn by looking at the EIGRP topoplogy table. We use the show ip eigrp topology command to list the contents of the EIGRP topology database.


R1#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(777)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.12.0/24, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/2
P 10.1.23.0/24, 2 successors, FD is 3072
        via 10.1.12.2 (3072/2816), GigabitEthernet0/2
        via 10.1.13.3 (3072/2816), GigabitEthernet0/3
P 10.1.13.0/24, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/3
P 2.2.2.2/32, 1 successors, FD is 130816
        via 10.1.12.2 (130816/128256), GigabitEthernet0/2
P 3.3.3.3/32, 1 successors, FD is 130816
        via 10.1.13.3 (130816/128256), GigabitEthernet0/3
P 1.1.1.1/32, 1 successors, FD is 128256
        via Connected, Loopback0
		
		
R2#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(777)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.12.0/24, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/1
P 10.1.23.0/24, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/3
P 10.1.13.0/24, 2 successors, FD is 3072
        via 10.1.12.1 (3072/2816), GigabitEthernet0/1
        via 10.1.23.3 (3072/2816), GigabitEthernet0/3
P 2.2.2.2/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 3.3.3.3/32, 1 successors, FD is 130816
        via 10.1.23.3 (130816/128256), GigabitEthernet0/3
P 1.1.1.1/32, 1 successors, FD is 130816
        via 10.1.12.1 (130816/128256), GigabitEthernet0/1

		
R3#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(777)/ID(3.3.3.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.12.0/24, 2 successors, FD is 3072
        via 10.1.13.1 (3072/2816), GigabitEthernet0/1
        via 10.1.23.2 (3072/2816), GigabitEthernet0/2
P 10.1.23.0/24, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/2
P 10.1.13.0/24, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/1
P 2.2.2.2/32, 1 successors, FD is 130816
        via 10.1.23.2 (130816/128256), GigabitEthernet0/2
P 3.3.3.3/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 1.1.1.1/32, 1 successors, FD is 130816
        via 10.1.13.1 (130816/128256), GigabitEthernet0/1		
Lesson tags: EIGRP, IOS, Routing
Back to: CCNA Routing and Switching 200-125 > EIGRP