Discontiguous Networks – Part 2 (Free Preview)

You must first complete Discontiguous Networks before viewing this Lesson
This is a preview lesson. Please purchase the course to access all lessons.

RIP and IGRP are classful protocols. Whenever RIP advertises a network across a different major network boundary, RIP summarizes the advertised network at the major network boundary. In Figure below, when R1 sends an update that contains 172.16.10.0/24 to R2 across 192.168.10.0/24, the router converts 172.16.10.0/24 into 172.16.0.0/16. This is known as auto−summarization.

 

 

Figure Network Diagram

 

Network Interface Connections

Device Interface IPv4 Address Device Interface IPv4 Address
R1 lo0 172.16.10.10/24
R1 Fa0/0 192.168.10.1/24 R2 Fa0/0 192.168.10.2/24
R2 Fa0/0 192.168.10.2/24 R1 Fa0/0 192.168.10.1/24
R2 lo0 172.16.20.10/24

 

R1 Configuration

R1#
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int fa0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#description TO_R2
R1(config-if)#no shut
R1(config-if)#int lo0
R1(config-if)#ip address 172.16.10.10 255.255.255.0
R1(config-if)#exit


R1(config)#router rip
!--- Enables a RIP routing process and enters router configuration mode. By default RIPv1 is enabled. ---!

R1(config-router)#network 192.168.10.0
!--- Associates interface 192.168.10.1 with the RIP routing process. ---!

R1(config-router)#network 172.16.0.0
!--- Associates interface 172.16.10.10 with the RIP routing process. ---!

R1(config-router)#exit
R1(config)#end
R1#

 

R2 Configuration

 

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int fa0/0
R2(config-if)#ip address 192.168.10.2 255.255.255.0
R2(config-if)#description TO_R1
R2(config-if)#no shut
R2(config-if)#int lo0
R2(config-if)#ip address 172.16.20.10 255.255.255.0
R2(config-if)#end
R2#     
R2#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 8/38/72 ms

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router rip
!--- Enables a RIP routing process and enters router configuration mode. By default RIPv1 is enabled. ---!

R2(config-router)#network 192.168.10.0
!--- Associates interface 192.168.10.2 with the RIP routing process. ---!

R2(config-router)#network 172.16.0.0
!--- Associates interface 172.16.20.10 with the RIP routing process. ---!

R2(config-router)#end
R2#

 

R1 Verification

 

R1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.10.1    YES manual up                    up      
Serial0/0                  unassigned      YES unset  administratively down down    
FastEthernet0/1            unassigned      YES unset  administratively down down    
Serial0/1                  unassigned      YES unset  administratively down down    
Loopback0                  172.16.10.10    YES manual up                    up      


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Loopback0
!--- R1 is not learning about the 172.16.20.0/24 subnet ---!


R1#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 20 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       1     1 2                                  
    Loopback0             1     1 2                                  
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
    192.168.10.0
!--- The two classful networks that the RIP routing process is advertising ---!
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.10.2         120      00:00:09
!--- The sources that the R1 is receiving routing updates ---!
  Distance: (default is 120)

 

R2 Verification

 

R2#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.10.2    YES manual up                    up      
Serial0/0                  unassigned      YES unset  administratively down down    
FastEthernet0/1            unassigned      YES unset  administratively down down    
Serial0/1                  unassigned      YES unset  administratively down down    
Loopback0                  172.16.20.10    YES manual up                    up      

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.20.0 is directly connected, Loopback0
!--- R2 is not learning about the 172.16.10.0/24 subnet ---!

R2#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 27 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       1     1 2                                  
    Loopback0             1     1 2                                  
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
    192.168.10.0
!--- The two classful networks that the RIP routing process is advertising ---!
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.10.1         120      00:00:27
!--- The sources that the R2 is receiving routing updates ---!
 
 Distance: (default is 120)

 

When Router  R1 Sends Updates to Router R2

 

R1#deug ip rip
RIP protocol debugging is on
R1#
*Mar  1 00:08:35.895: RIP: sending v1 update to 255.255.255.255 via Loopback0 (172.16.10.10)
*Mar  1 00:08:35.895: RIP: build update entries
*Mar  1 00:08:35.895: 	network 192.168.10.0 metric 1
R1#
*Mar  1 00:08:51.131: RIP: received v1 update from 192.168.10.2 on FastEthernet0/0
*Mar  1 00:08:51.131:      172.16.0.0 in 1 hops
!--- R2 is saying Hey R1, network 172.16.0.0 is reachable me---!
!--- However, R1 already has a connected interface that belongs to major network 172.16.0.0/16. Therefore R1 does not install the route from R2 in the routing table. ---!
R1#
*Mar  1 00:08:52.287: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.10.1)
*Mar  1 00:08:52.287: RIP: build update entries
*Mar  1 00:08:52.287: 	network 172.16.0.0 metric 1

 

When Router R2 Sends Updates to Router R1

R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar  1 00:08:51.159: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.10.2)
*Mar  1 00:08:51.159: RIP: build update entries
*Mar  1 00:08:51.159: 	network 172.16.0.0 metric 1
*Mar  1 00:08:52.091: RIP: sending v1 update to 255.255.255.255 via Loopback0 (172.16.20.10)
*Mar  1 00:08:52.091: RIP: build update entries
*Mar  1 00:08:52.091: 	network 192.168.10.0 metric 1
R2#
*Mar  1 00:08:52.323: RIP: received v1 update from 192.168.10.1 on FastEthernet0/0
*Mar  1 00:08:52.327:      172.16.0.0 in 1 hops
!--- R1 is saying Hey R2, network 172.16.0.0 is reachable through me---!
!--- However, R2 already has a connected interface that belongs to major network 172.16.0.0/16. Therefore R2 does not install the route from R1 in the routing table. ---!

 

The behavior of RIPv1 and IGRP is such that when R1 and R2 exchange updates, both R1 and R2 do not learn about the attached subnetworks of 172.16.10.0/24 and 172.16.20.0/24. As a result, devices on these two subnetworks are unable to communicate with each other.

 

 

 

Figure RIPv1 routing advertisement

Lesson tags: CCNA, Cisco, GNS3, RIP, Routing, Static Routes
Back to: Practical Network Lessons > Network Lessons - Routing Concepts